Can't run Stackedit 5 in FF 58.02 Linux



I noticed that StackeEdit 5 won’t load. I just get the white page with the StackEdit logo in the middle. There are no sidebars to do anything. My FF console shows this error:

Error: Can’t connect to IndexedDB.
TypeError: ServiceWorker script at for scope encountered an error during installation.

I’ve toggled some of the service worker settings in about:config but can’t find something that works. I have also verified that I am not in Incognito mode because that seems to be a known issue.

It works fine in other browsers. Any ideas how to troubleshoot this further?


Technical problem: doesnt work on chrome, but does on firefox - what settings need to be on?

Bump. Need some ideas to get this working. Currently not terribly useful because I choose not to use Chrome.


I just wanted to mention that I am experiencing the same issue with Firefox 58.0.2 (64-bit) in Windows 7.


I eventually deleted all instances of indexedb in my Firefox folder and it worked. Something must have had it locked or something like that. On Linux, it looked like this:

[ ~/.mozilla ]$ find . | grep -i indexed
[ ~/.mozilla ]$ rm -rf ./firefox/vlbfrvsu.default

Your mileage may vary.


If I’m reading that correctly, you deleted more than just the indexeddb instances. It looks like you removed all the contents of vlbfrvsu.default, and maybe even vlbfrvsu.default itself. That is a whole lot of stuff!

I tried deleting just the indexeddb+++fx-devtools directory, and that did not seem to have any effect.


I guess you have to disable private navigation. See